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Introduction
What is the DWmail Notifier

DWmail™ Notifier is a Windows application that alerts you when you have new messages in your
DWmail inbox. From the Notifier you can also browse the last 25 messages. It displays an icon in your
system tray and shows you subjects, who the message is from and the size, all without the need to open
your Web browser.

What is the Software Development Kit (SDK)

This SDK is available for registered clients of DWmail who wish to customise the default settings and re-
bundle DWmail Notifier for their own DWmail installation.

How to get the SDK

Only existing license holders of DWmail can download and use the SDK. This is available for download from
the Dominion Web Client Download area at http://downloads.dominion-web.com/

Requirements for the SDK
The DWmail Notifier SDK has the following requirements:

*  Microsoft Visual Studio 2008 (The SDK may work with 2005 but has not been tested with this

version)

=  NET Framework 2.0



http://downloads.dominion-web.com/
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Using the SDK

Opening the SDK

Once you have downloaded the SDK from the Dominion Web download area, double click on the
executable Notifier SDK.exe file.

This is a self extracting ZIP file. Itis recommended you select your Visual Studio Projects folder as the
path to unzip the SDK to.

Once you have unzipped the SDK navigate to your Visual Studio Projects Folder. This is you usually in
your Documents folder under “Visual Studio 2008\Projects’. A folder called Notifier SDK will have
been created containing the DWmail Notifier SDK project solution.

Navigate to the Notifier SDK folder and double click on the | Selution Explorer - DWmail Notifier.. v & X
‘DWmail Notifier Setup SDK.sln’ solution file. This will NN e o o B

open Visual Studio 2008 with the SDK loaded. ] Solution ‘DWmail Notifier Setup’ (1 project

= [g) DWmail Notifier Setup
+ [ Detected Dependencies
‘.. «3 DevComponents.DotNetBar2.dll
<3 Dominion.RSS.Library.dll
- 2] mail_error.ico
- 2] mail_exchange.ico

The Solution Explorer will show one open setup project
called ‘DWmail Notifier Setup’.

Customising the Client Name

When the Notifier is loaded the application name is
displayed in the system tray, preferences window and context
menu. This can be changed using the SDK by editing the
file ‘Notifier.exe.config’.

- =] mail_new.ico

- 2] mail_server.ico
- 2] Notifier.exe.config
o <3 Notifier.exe

. 2] notify.wav

Right click on this file and select ‘Open’ in the Solution =) splash.jpg
Explorer

Find the section entitled:
<setting name="AppName" serializeAs="String">
<value>DWmail Notifier</value>
</setting>

Edit the text within the <value> and </value> tags to reflect the name you wish to use for the Notifier.
Note this will not change the application name under Context Menu -> About dialog.
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Customising the About Dialog

Notifier’s about dialog can have a custom paragraph of text displayed at the bottom of the screen.
When a user clicks on this paragraph it can link to a URL of your choice. This can be set using the SDK
by editing the file ‘Notifier.exe.config’.

Right click on this file and select ‘Open’ in the Solution Explorer

Find the section entitled:
<setting name="SDKLink" serializeAs="String">
<value />
</setting>
<setting name="SDKLinkText" serializeAs="String">
<value />
</setting>

Change <value /> to <value>Your Custom Text</value> to reflect the URL and the paragraph you
wish to use. Make sure this text is XML compliant.

Changing the Splash Screen

When the Notifier loads, a splash screen is displayed. A file called splash.jpg can be modified to replace
the default splash screen. Simply open this file with your favourite image editing tool, edit and save.

DWmai | natifier

Properties v 3 X

Please note that the dimensions are fixed and if splash.jpg is

not present, the default splash screen will be used. DWmail Notifier Setup Deployment Project ~

=
B Mis

AddRemovePrograr (Icon)
Author

Description

Editing the Setup Project Name

The setup project name is the name used for the installation
directory, the name in the installer and the name in the
Add/Remove Programs section of the Windows Control
Panel.

Dominion Web

DetectNewerlnstalle True

InstallAllUsers False
Single click on the Setup Project root called ‘DWmail Keywords
Notifier Setup’ in the Solution Explorer. Localization English (United States| _

Manufacturer Dominion Web
The Properties section will now give you the options you can

change.

ManufacturerUrl
PostBuildEvent
PreBuildEvent
ProductCode {75804 CF9-CCBF-4BF
ProductName DWmail Notifier

http://www.dominior

You may wish to change the following Properties

= Author
= Description

=  Manufacturer is your company name

RemovePreviousVer True
RunPostBuildEvent On successful build
SearchPath

Subject

SupportPhone i

Civimmm w1l b Miiainis Admmmiomine
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=  ManufacturerUtl to your own website

* ProductName of the application

= SupportPhone to your telephone number if you offer telephone support to your customers

= SupportUrl to the URL of your support area if you offer such a tool to your customers

= Title

®  Version (the Setup Process will automatically upgrade and remove older versions but if this
version number is the same as one already installed then the setup process will require the end

user to manually remove via the control panel first. This can be run side by side with the
Notifier available from Dominion Web however)
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Registry

Editing the URL to your DWmail installation

The registry settings are the key to configuring DWmail Notifier to your specific DWmail installation by
default..

To access the registry settings, right click on ‘DWmail Notifier Setup’ in the Solution Explorer and select
‘View -> Registry’

55| File System
g5 Registry

J] File Types Install
9| UserInterface Uninstall
“@ Custom Actions # | Cut

a. Launch Conditions X | Remove

Rename

Properties

The main workspace will change to the registry layout for the Notifier. These are registry settings used
by the Notifier to setup its settings and account connection details.

Registry (DWmail Notifier Setup)

::*d Registry on Target Machine
.[23 HKEY_CLASSES_ROOT

@23 HKEY_CURRENT_USER

-8 HKEY_LOCAL_MACHINE

.23 HKEY_USERS
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All of the changes needed for the registry are under HKEY_CURRENT_USER (HKCU). Click on the
+ icon to expand and navigate to ‘HKCU\Software\DWmailNotifier’

Name Value

ia] AllowInvalidSSL 0

fﬂﬂ Configured 0

;‘PJ DefaultAccount "Accountl”
f-,'tﬂ PlaySound

fl_'fﬂ Proxy

&b] ProxyDomain

EPJ ProxyPassword

&) ProxyServer "http://"
;‘}ﬂ ProxyType "Basic"
,f,‘ﬂ ProxyUser

] Refresh "30"

iia] Skin 1
EoﬂTransparency 90

k] URL "http://"

These are the core registry keys to DWmail Notifier’s behaviour

‘HKCU\Software\DWmailNotifier’

AllowInvalidSSL — If you are using an SSL certificate to connect to your DWmail installation but
it is either self signed or expired then set this to 1 to bypass certificate validation

Configured — For new installations this should be set to 0

DefaultAccount — The default account registry name. For new installations this should not be
changed

PlaySound — Play a new mail notification sound if set to 1

Proxy — Set to 1 to enable a proxy server

ProxyDomain — The domain for a proxy server

ProxyPassword — Proxy Password

ProxyType — The proxy server type ‘Basic’, ‘Digest’ or ‘Kerboros’

ProxyUser — The username for the proxy server

Refresh — The time in seconds to check for new mail

Skin — The default skin for the notifier. Can be 1-3

Transparency — The % opacity of the notifier window

URL — The most important key to configure, the URL to your DWmail installation. Do not
include a trailing forward slash.

Single clicking on any of these keys will change the Properties dialog to allow you to edit it.
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Properties v B X

(Name) URL

Condition
Transitive True

Value http://

ne

Edit the “Value’ field to reflect the new value for the registry key.

Configuring a default webmail account
Navigate to HKEY_CURRENT_USER (HKCU) and then to

‘HKCU\Software\DWmailNotifier\ Account1’
* This is the default account for the Notifier, do not rename the key itself, however to configure a
default account you can modify any of the sub keys
o Description — The name of the account shown to the user when running the Notifier
o Hash — The user key, this is a dynamically generated hash key shown to the user on the
RSS preferences page from within DWmail
o ID —The user id, shown to the user of the RSS preferences page from within DWmail

Setting DWmail Notifier to load on Windows startup
Navigate to HKEY_CURRENT_USER (HKCU) and then to

‘HKCU\Software\Microsoft\Windows\ CurrentVersion\Run’
* The only entry here is DWmail Notifier and the path to Notifer.exe. You can change the name
of the key to reflect your application name.
" This key is only installed if the user ticks the checkbox on installation.
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Start Menu

Start Menu Shortcuts

To access the Start Menu Shortcuts, right click on ‘DWmail Notifier Setup’ in the Solution Explorer and
select “View -> File System’

Ll DOIUTION UYVMaN NOTTIEN DETUP (L Pre
=B} DWmail Notifier Setup

il g g:‘r’:‘: Rebuild |
5 File System View »
&3 | Registry Add »
_Js;) File Types Install
9| UserInterface Uninstall
’2 Custom Actions % | Cut
G2 8 . Launch Conditions X | Remove

Rename

‘=) Properties

The Workspace will now change to show the installation file system.
Navigate to ‘User’s Programs Menu’

Click on ‘DWmail Notifier’ and the Properties dialog will change. To edit the name of the folder you
can edit the (Name) field.

Navigate to ‘Uset’s Programs Menu\DWmail Notifier’ and click on the file ‘DWmail Notifier’. This is
the icon on the start menu to load the Notifier’s settings dialog. The Properties dialog will change and

you can edit the following fields:

* (Name) — The name of your application in the shortcut
* Description — A description tooltip that appears when you hover over the shortcut

The other dialog options should not need to be edited.
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Building the Setup Files
Changing the MSI file name

To access the Build Options , right click on ‘DWmail Notifier Setup’ in the Solution Explorer and select
‘Properties’

Make sure the current Configuration is set correctly by clicking on ‘Configuration Manager’ and making
sure both projects are set to ‘Release’

Configuration Manager . ™

Active solution configuration: Active solution platform:
Release v] [ Default v]
Project contexts (check the project configurations to build or deploy):
Project Configuration Platform Build
DWmail Notifier Setup Release E]

Close

Change the ‘Output file name:” to the directory and name of the MSI file you wish to create when the
project is built.
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DWmail Notifier Setup Property Pages @l.:_hj
Configuration: | Active(Release) ¥ | Platform: | N/A LConfiguration Manager... ]
Configuration Properties
Build Output file name: Release\notifier.msi B
Package files: [In setup file ']
Compression: lOptimized for speed "

\: Unlimited

Custom:

Installation URL:

ok || Cancel Apply

Prerequisites

Prerequisites are packages required before DWmail Notifier can be installed and run. You can access
these by clicking on the ‘Prerequisites’ button. By default ‘NET Framework 2.0’ and ‘Windows Installer
3.17 are selected as they are required by DWmail Notifier.

Prerequisites will automatically download at the same time as installation from Microsoft’s website if
they are not already installed.

Building the setup files

To access built the setup files, right click on ‘DWmail Notifier Setup’ in the Solution Explorer and select
‘Build’.

The Output dialog will show you the build process and assuming no mistakes have been made when
editing the SDK files, the process will complete.

The setup files will be located in your documents folder in the subfolder ‘Visual Studio
2008\ Projects\Notifier SDK\ DWmail Notifier Setup\Release\’

There are two files, setup.exe and (if the output name was not changed above) notifier.msi. notifier.msi
is the only file required for the setup, however setup.exe is a bootstrap wrapper that includes the
detection of the prerequisites such as NET 2.0 Framework.
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